Resolved
AWS has confirmed this incident is resolved.
Monitoring
We are no longer seeing any impacting clusters in the AWS us-east-1 region. We're continuing to monitor the situation.
Monitoring
AWS has now acknowledged a us-east-1 EC2 Launch Template API incident impacting EKS node provisioning/scaling (incl. Karpenter). We are continuing to monitor the situation.
Investigating
AWS has published a status update for this issue. We are actively monitoring their progress and will continue to share updates.
https://health.aws.amazon.com/health/status?path=service-history
Investigating
We are investigating node scaling issues in the AWS us-east-1 region. Customers may experience issues with worker scale-up and new task startup.