Resolved
The incident is fully resolved and all Azure clusters in EastUS2 are functioning as expected.
Monitoring
Engineers observe that affected clusters are returning to "healthy" status.
Investigating
We have detected node scaling issues in the Azure EastUS2 region and are currently investigating.