Resolved
This interruption has been resolved.
Monitoring
Affected clusters have recovered and are operating normally. We are continuing to monitor the environment to ensure service stability.
Investigating
We are investigating intermittent connectivity issues affecting clusters in Azure Central US when calling Astronomer APIs. This may prevent or delay attempts to create, update, or delete Airflow Deployments. Our engineering team is actively investigating the issue and working to restore normal service.