Airflow UI and API Unavailable for a few customers

Incident Report for Astro

Resolved

We have confirmed that no additional clusters were affected beyond those that were initially identified. This incident is fully resolved.
Posted Mar 24, 2025 - 14:50 UTC

Identified

We have identified that this issue is specific to clusters that have custom networking, specifically route tables that require a carve-out for traffic back to Astro's control plane. The public IPs for the control plane were changed, and certain custom networking setups required that the IPs be updated accordingly.

We have fixed this for all customers who reported this issue and are checking all clusters to determine if there are any others affected.
Posted Mar 24, 2025 - 14:23 UTC

Investigating

We are experiencing an issue in a few clusters, causing the Airflow UI and API to become unavailable.
The team is actively investigating the issue.
Posted Mar 24, 2025 - 10:30 UTC
This incident affected: Astro Hosted (Deployment Access, Cloud UI, Cloud API).