Unable to submit support request from Astro UI

Incident Report for Astro

Resolved

The issue was identified. Now support requests can be submitted again via Astro UI
Posted Sep 14, 2023 - 00:38 UTC

Investigating

The form to submit support request on Astro UI is not working for few of our customers.
Customers can reach us via support@astronomer.io.
Posted Sep 13, 2023 - 23:33 UTC
This incident affected: Astro Hybrid (Cloud UI) and Astro Hosted (Cloud UI).