Deployments on Astronomer Runtime 3.2-3 are returning 403 errors when accessing dags page.

Incident Report for Astro

Resolved

Our team has determined this only affects internal access, Astro end users are unaffected.
Posted May 06, 2026 - 20:05 UTC

Investigating

Attempting to access the dags page in the Airflow UI results in a 403 Forbidden error. This should not be affecting task execution.
Posted May 06, 2026 - 19:56 UTC
This incident affected: Astro Hosted (Deployment Access).