Deployment metrics sometimes failing to load

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Mar 27, 2024 - 02:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 02:42 UTC

Identified

Listing or viewing some deployments will display "metrics failed to load" instead of showing Dag Run and Task Instance summaries. Actual DAG Runs and tasks are continuing to execute correctly, and the Airflow UI is still accessible. We have identified the problem and are working on deploying a fix.
Posted Mar 26, 2024 - 23:19 UTC
This incident affected: Astro Hybrid (Cloud UI) and Astro Hosted (Cloud UI).