Runtime 3.2-1 Yanked - Incompatible with Env Manager

Incident Report for Astro

Resolved

Astronomer Runtime 3.2-2 has been released with the fix.
Posted Apr 16, 2026 - 22:25 UTC

Identified

We have identified that Runtime 3.2-1 is incompatible with the Astro Environment Manager. Any Connections or Variables stored at the Workspace level will not be available on deployments running 3.2-1. For this reason, we have disallowed the use of 3.2-1 for any deployments which are not already on that version. We are working to release a 3.2-2 version that is properly compatible as quickly as possible.
Posted Apr 16, 2026 - 18:04 UTC
This incident affected: Astro Hosted (Deployment Management).