Astro UI performance may be severely degraded or unavailable

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:58 UTC

Monitoring

Deployment Health Incidents may not be working
https://www.astronomer.io/docs/astro/deployment-health-incidents
Posted Oct 30, 2025 - 00:51 UTC

Update

Deployment Health Incidents may not be working
https://www.astronomer.io/docs/astro/deployment-health-incidents
Posted Oct 30, 2025 - 00:51 UTC

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 23:57 UTC
This incident affected: Astro Hybrid (Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Cluster Management), Astro Hosted (Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Dashboards and Analytics), and Astro Observe.