Astro Core API performance degradation

Incident Report for Astro

Resolved

The Astro Core API issue has been fixed, and all components are now fully operational.
Posted Jan 29, 2026 - 11:33 UTC

Monitoring

Our engineering team has applied a fix that should help mitigate the issue. We are currently monitoring the situation and are seeing internal improvements. We will continue to provide updates as we learn more.
Posted Jan 29, 2026 - 11:02 UTC

Investigating

Users may experience slow loading in the Astro UI, and Astro deploys may fail intermittently. We're investigating the issue and will provide updates as soon as more information becomes available.
Posted Jan 29, 2026 - 10:30 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks, Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Dashboards and Analytics), Astro Hybrid (Scheduling and Running DAGs and Tasks, Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Cluster Management), and Astro Observe.