Airflow API 500 Errors
Incident Report for Astro
Resolved
The incident has been resolved. During this time, DAGs that were making API calls to Airflow deployments may have failed - those tasks can now be reran.
Posted May 22, 2024 - 18:53 UTC
Investigating
When accessing the Airflow API programmatically, requests may fail and return an HTTP 500 status code. We are investigating the cause of this issue.

Access through the UI is unaffected and all DAGs will continue to run as normal.
Posted May 22, 2024 - 18:29 UTC
This incident affected: Astro Hybrid (Cloud API) and Astro Hosted (Cloud API).