Astro deployments in GCP us-central-1 experiencing issues

Incident Report for Astro

Resolved

The GKE incident is now resolved per Google, and we are seeing that all related issues appear to have cleared up on Astro. If you are still experiencing an issue, please raise a support ticket.
Posted Mar 09, 2026 - 16:11 UTC

Identified

We are seeing signs of recovery across some affected clusters.
Posted Mar 09, 2026 - 15:30 UTC

Update

Google has confirmed to Astronomer that this is an issue with GKE in the region. We are following the issue closely.
Posted Mar 09, 2026 - 13:53 UTC

Investigating

Some pods in us-central-1 are experiencing CrashLoopBackoff errors. Because at least some of these errors are affecting the components that control Dag-only deploys, newly scaled up worker pods are being affected in at least some cases. We are actively investigating.
Posted Mar 09, 2026 - 13:29 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks, Deployment Management) and Astro Hybrid (Scheduling and Running DAGs and Tasks, Deployment Management).