Astro CLI cannot access Airflow variables and connections
Incident Report for Astro
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 22:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2023 - 20:11 UTC
Identified
When using the Astro CLI to access deployments variables and connections, you may receive the following error failed to decode response from API. If modifying the variables or connections and you receive this message, the modifications have not taken effect.

Examples of CLI commands that may fail are:
- astro deployment airflow-variable list
- astro deployment connection list
- astro deployment connection update

Our team has identified the issue and is releasing a fix.
Posted Nov 08, 2023 - 19:19 UTC
This incident affected: Astro Hybrid (Deployment Management) and Astro Hosted (Deployment Management).