Stuck worker pods resulting in tasks failing in the queued state

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Apr 19, 2025 - 06:12 UTC

Update

The incident is resolved.
Posted Apr 18, 2025 - 21:36 UTC

Update

We are continuing to investigate this issue.
Posted Apr 18, 2025 - 19:12 UTC

Investigating

In some deployments, worker pods are getting stuck in the initialization state for an extended period of time. Due to this, queued tasks are unable to run and fail.

This is not affecting all deployments. We are investigating which deployments are affected and why.
Posted Apr 18, 2025 - 14:25 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks) and Astro Hybrid (Scheduling and Running DAGs and Tasks).