AWS Cluster Creation is Failing

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Jan 17, 2026 - 00:19 UTC

Update

All system functionality has been restored and is operational.
Posted Jan 17, 2026 - 00:14 UTC

Update

The fix has been released and verified and it will become available across Astronomer infrastructure over the next hour.
Posted Jan 16, 2026 - 23:39 UTC

Identified

We have identified the root cause and are working on releasing a fix.
Posted Jan 16, 2026 - 20:22 UTC

Update

We have confirmed that existing clusters are unaffected. We are testing a potential workaround to create AWS clusters.
Posted Jan 16, 2026 - 18:08 UTC

Update

We are continuing to investigate this issue.
Posted Jan 16, 2026 - 17:00 UTC

Investigating

Creation of AWS clusters is failing. At the moment, we do not think this impacts existing clusters, but we are working on getting confirmation for this.
Posted Jan 16, 2026 - 16:59 UTC
This incident affected: Astro Hosted (Deployment Management).