Some Azure clusters unable to scale worker nodes.

Incident Report for Astro

Resolved

Mitigations have been fully applied across all affected regions by Azure, and validations confirm that configurations have been successfully updated.

Customers should now see full recovery of service management operations, and dependent services are operating as expected.
Posted Feb 03, 2026 - 08:56 UTC

Update

We are now seeing additional clusters being affected. Issue is still ongoing.
Posted Feb 03, 2026 - 01:50 UTC

Monitoring

We are still waiting on confirmation from Azure that the issue has passed, but we are no longer seeing impact to Astronomer workloads.
Posted Feb 03, 2026 - 00:23 UTC

Identified

Azure has confirmed the outage. Please see their status page for additional information
https://azure.status.microsoft/en-us/status
Posted Feb 02, 2026 - 21:46 UTC

Update

We are continuing to investigate this issue.
Posted Feb 02, 2026 - 20:43 UTC

Investigating

An potential Azure outage is resulting in some Azure clusters being unable to scale worker nodes. As a result, some tasks may fail. We are investigating internally and working with Azure to restore service as soon as possible.
Posted Feb 02, 2026 - 20:43 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks).