Dashboard cost breakdown data delays

Incident Report for Astro

Resolved

This incident is now resolved, and all Cost Breakdown data is now up to date. The issue that caused the delay has been fixed and should not recur.
Posted May 04, 2026 - 20:15 UTC

Update

We are continuing to investigate this issue.
Posted May 04, 2026 - 10:56 UTC

Investigating

We’re investigating an issue affecting Dashboard cost breakdown data. For affected customers, cost breakdown information may appear stale and may not have updated since May 1, 2026. Our team is actively investigating the cause and working to restore current data. We’ll share another update as we have more information.
Posted May 04, 2026 - 10:56 UTC
This incident affected: Astro Hosted (Dashboards and Analytics).