Creating a Connection can crash the browser tab

Incident Report for Astro

Resolved

This issue has been resolved.
Posted Jun 06, 2025 - 15:18 UTC

Identified

The issue has been identified, and our team is actively working on a fix.
Posted Jun 06, 2025 - 12:48 UTC

Investigating

If you create certain Connection types in the Environments menu, it can crash your browser tab. Currently it affects SSH, SMTP, SFTP, Postgres, and Generic. There could be others. We are investigating currently.
Posted Jun 05, 2025 - 23:48 UTC
This incident affected: Astro Hosted (Cloud UI).