GCP us-east1 incident may affect Astro clusters in this region

Incident Report for Astro

Resolved

Per Google, this outage is now resolved.
Posted Jul 18, 2025 - 18:33 UTC

Investigating

Google Cloud has put up a status page indicating that several services in us-east1 are affected by an incident. Astro clusters in this region will be affected by this. Clusters in other regions and other clouds should not be affected, as none of the control plane components for Astro are hosted in this region.

For more information, follow the GCP incident:

https://status.cloud.google.com/incidents/8cY8jdUpEGGbsSMSQk7J
Posted Jul 18, 2025 - 16:25 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks).