Tasks unable to run due to worker issues

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 00:33 UTC

Monitoring

We have reverted the update that was rolled out. We are seeing worker pods in affected deployments running tasks now. We will continue monitoring this incident.
Posted Nov 17, 2025 - 18:42 UTC

Investigating

We have found workers failing to heartbeat on several Airflow 3 deployments. Due to this tasks are unable run and eventually fail. This issue might be due to an update for the Astro Agent plugin that was rolled out today. We are currently investigating this.
Posted Nov 17, 2025 - 18:13 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks) and Astro Hybrid (Scheduling and Running DAGs and Tasks).