Azure Front Door CDN issue causing timeouts to Astro Cloud UI

Incident Report for Astro

Resolved

Resolved per Azure status; https://azure.status.microsoft/en-us/status
Posted Oct 30, 2025 - 00:49 UTC

Update

We are continuing to monitor for any further affects from this Azure outage.

You can follow Azure's status here: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 16:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 16:05 UTC

Investigating

We are currently investigating an apparent issue with Azure's Front Door CDN that is causing DNS timeouts and unavailability of the Astro Cloud UI. Airflow deployments are unaffected and continue to process tasks.

We have updated our DNS routing to bypass Front Door for now and are seeing access to the Cloud UI being restored.
Posted Oct 29, 2025 - 16:05 UTC
This incident affected: Astro Hybrid (Cloud UI) and Astro Hosted (Cloud UI).