Terminating Workers Accepting Tasks Causing Failures in Astro Executor

Incident Report for Astro

Resolved

This issue has been resolved.
Posted Apr 17, 2026 - 11:47 UTC

Monitoring

The fix has been implemented, and we are now monitoring the deployments.
Posted Apr 17, 2026 - 10:01 UTC

Identified

We have identified the issue and we are rolling out the fix for the affected deployments.
Posted Apr 17, 2026 - 08:05 UTC

Investigating

We have identified an issue with Astro Executor deployments where terminating workers can continue to accept new tasks, which can, in some cases, can cause these tasks to fail.
Posted Apr 17, 2026 - 08:04 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks) and Astro Hybrid (Scheduling and Running DAGs and Tasks).