Astro Core API performance degradation

Incident Report for Astro

Resolved

The Astro Core API issue is fixed and all components are operational now.
Posted Nov 24, 2025 - 22:11 UTC

Monitoring

We have identified the degraded performance in Astro Core API and applied the fix. We are currently monitoring the issue.
Posted Nov 24, 2025 - 20:50 UTC

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 20:49 UTC

Investigating

Users may experience slow loading in the Astro UI. We’re investigating the issue and will provide updates as soon as we have more information.
Posted Nov 24, 2025 - 20:20 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks, Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Dashboards and Analytics) and Astro Hybrid (Scheduling and Running DAGs and Tasks, Deployment Access, Deployment Management, Cloud UI, Cloud API, Cloud Image Repository, Cluster Management).