Task failures on deployments using AstroExecutor

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 13:42 UTC

Monitoring

The fix has been applied to the affected deployments, and the issue should no longer be observed.
Posted Feb 05, 2026 - 13:42 UTC

Identified

We have identified an issue with some Astro Executor deployments where the graceful termination period of workers is not respected, leading to potential task failures. We are rolling out a fix for the affected Deployments
Posted Feb 05, 2026 - 12:41 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks).