Azure East US multiservice outage impacting Astro deployments in the region

Incident Report for Astro

Resolved

Azure has confirmed the issue is resolved and services are back to normal. This incident is now closed.
For more details, see the Azure incident history: https://azure.status.microsoft/en-us/status/history/
Posted Apr 25, 2026 - 05:05 UTC

Monitoring

Azure has fixed the issue, and services are back to normal in East US. We are monitoring to make sure everything stays stable.
Posted Apr 25, 2026 - 03:56 UTC

Identified

Azure East US has reported multi-service impact that is affecting Astro deployments in the region. For more information on Azure outage, please visit: https://azure.status.microsoft/en-us/status
Posted Apr 24, 2026 - 17:28 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks, Deployment Management, Cloud Image Repository) and Astro Hybrid (Scheduling and Running DAGs and Tasks, Deployment Management, Cloud Image Repository).