Airflow incorrectly being reported as being deployed

Incident Report for Astro

Resolved

The issue has been fixed and all deployment information is accurate.
Posted Mar 07, 2025 - 17:33 UTC

Identified

We have identified an issue where Airflow deployments are incorrectly being marked as being deployed. This causes the "Open Airflow" button in the Astro UI to be greyed out. Despite being greyed out, the "Open Airflow" button will still work, and the deployment is still able to be accessed. This does not affect the running Airflow deployments, so no DAGs will be affected.
Posted Mar 07, 2025 - 17:14 UTC
This incident affected: Astro Hybrid (Deployment Access) and Astro Hosted (Deployment Access).