Certain Shared Deployments in AWS US West 2 are down

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 19:30 UTC

Monitoring

We have restored the Shared Cluster to functionality. We are monitoring for any further disruptions.
Posted Feb 20, 2025 - 17:32 UTC

Investigating

A particular shared cluster in AWS US West 2 is experiencing an issue with its database server that is causing an outage. 20% of shared cluster deployments in this region are affected. We are working to restore operations as quickly as possible.

Deployments on Dedicated Clusters and Deployments in other clouds or regions are unaffected.
Posted Feb 20, 2025 - 16:37 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks, Deployment Access).