Cost Breakdown Dashboard data update delayed

Incident Report for Astro

Resolved

This issue is now resolved except for one customer who we have contacted directly.
Posted Apr 07, 2025 - 19:18 UTC

Update

Deployment cost is now up to date, but compute costs for some customers remain outdated. We were working with our billing vendor to determine the source of the issue.
Posted Apr 07, 2025 - 16:43 UTC

Identified

Data shown in the Organization Dashboards Cost Breakdown (for Enterprise customers) is delayed. As stated on the page itself, the latest data is as of April 4th. The processing to update this dashboard is currently ongoing, and we expect the data to be refreshed at approximately 16:00 UTC.
Posted Apr 07, 2025 - 13:42 UTC
This incident affected: Astro Hosted (Cloud UI).