Issues with EC2 scale up time in AWS us-east-1, use1-az2 Availability Zone causing node scale up issues for some deployment in AWs us-east-1

Incident Report for Astro

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 23:51 UTC

Monitoring

Customer deployments should no longer be affected, we are monitoring to confirm resolution.
Posted Oct 28, 2025 - 19:39 UTC

Investigating

We are currently investigating this issue and have been notified by AWS of issues with VM scale ups in AWS us-east-1, specifically the use1-az2 AZ. We are working to identify affected deployments, as well as on mitigations.
Posted Oct 28, 2025 - 18:05 UTC
This incident affected: Astro Hosted (Scheduling and Running DAGs and Tasks) and Astro Hybrid (Scheduling and Running DAGs and Tasks).