Delayed delivery for some time-based alerts

Incident Report for Astro

Resolved

The incident has been resolved.
Posted May 07, 2026 - 14:24 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted May 07, 2026 - 13:49 UTC

Update

A fix has been prepared and is moving through deployment. We will provide another update once the rollout is complete and validation is underway.
Posted May 07, 2026 - 12:57 UTC

Identified

We have identified the cause of the delayed delivery for some time-based alerts and are implementing a fix. We will provide another update once the fix has been deployed and validated.
Posted May 07, 2026 - 11:15 UTC

Investigating

We are investigating delayed delivery for some time-based alerts. The delay is primarily visible for DAG Timeliness alerts, and may also affect Observe-related SLA, Proactive SLA, and Data Quality monitor alerts. DAG Duration and Task Duration alerts do not appear to be affected at this time.
Posted May 07, 2026 - 10:31 UTC
This incident affected: Astro Observe.