Astro CLI 1.35 may unintentionally modify worker queue configurations

Incident Report for Astro

Resolved

We’ve verified that all affected customers have been contacted regarding the issue with Astro CLI version 1.35.0.
Posted Jul 01, 2025 - 18:25 UTC

Update

Deploys using Astro CLI version 1.35 are now blocked to prevent unintentional changes to worker queues. Please use CLI version 1.34 or lower.
Posted Jul 01, 2025 - 16:55 UTC

Identified

We’ve identified the root cause of the issue in Astro CLI version 1.35 that results in unintentional modifications to worker queues. We have yanked Astro CLI 1.35.

Yanked release: https://github.com/astronomer/astro-cli/releases/tag/v1.35.0
Posted Jul 01, 2025 - 14:03 UTC

Investigating

Upgrading to Astro CLI version 1.35 can lead to unintended changes in your worker queues settings, particularly when deploying with modified or missing workerQueues definitions. Please use CLI version 1.34 or lower.
Posted Jul 01, 2025 - 13:59 UTC
This incident affected: Astro Hybrid (Deployment Management) and Astro Hosted (Deployment Management).